Boomi Integration release notes for 21 Sep 2019

The following list shows the bug fixes in the 21 September 2019 re-release of the Dell Boomi platform.

Subject to the terms and conditions of our existing contract with your firm, and liability provisions and limits therein, we confirm that Boomi has successfully passed all applicable test cases associated with the updates identified in this product release.

Release notes for the 12 months preceding the current release are archived.

Issue summary

Enhancements

AreaIDSummary
AtomSphere API and Partner APIINT-1216Currently, non-environment accounts are not required to specify an environmentId when making CREATE Deployment API requests.

In order to maintain backward compatibility with the migration of non-environment accounts to Basic environment accounts, Basic environment accounts can continue to make CREATE Deployment API requests without specifying an environmentId.

To learn more about this enhancement, see the Community article Migrating Integration Accounts without Environments to Basic Environments and Deployment object (Legacy deployment).

Fixes

AreaIDSummary
PlatformINT-1218The Edit the default values of this function button is unresponsive for user-defined map functions. With this release, the functionality of the edit button is reinstated.
AtomINT-1233The September 2019 Atom release (v19.09.1) introduced an Atom library which conflicts with an existing library.

Dell Boomi has fixed this issue in Atom v19.09.2. With this release, the libraries are corrected to no longer conflict. If you are experiencing Atom issues, you can request v19.09.2 from Support.